Sicherheitsupdates(DSA 3786-1 &DSA 3799-1 &DSA 3808-1... &DSA 3885-1)

Sicherheitsupdates(DSA 3786-1 &DSA 3799-1 &DSA 3808-1... &DSA 3885-1)

Sicherheitsupdates für vim, imagemagick, imagemagick, icu, firefox-esr, weechat, ghostscript, libxstream-java, tomcat7, tomcat8, tiff, libtirpc, libytnef, xen, git, kde4libs, rtmpdump, bitlbee, bind9, jbig2dec, deluge, mysql-connector-java, puppet, imagemagick, fop, mosquitto, strongswan, sudo, openldap, tnef, wordpress, perl, ettercap, libmwaw, otrs2, tor, zziplib, libosip2, libgcrypt20, firefox-esr, request-tracker4, gnutls28, irssi. Sicherheitsanfälligkeit DSA-3786-1 vim —Sicherheitsupdates Auszug der Sicherheitsdatenbank: Sprachdateien des vim (Vi IMproved) Texteditors können zu einem Integer-Speicherüberlauf bei der Speicherreservierung führen, die einen Pufferüberlauf auslösen, durch welchen potentiell die Möglichkeit zum Ausführen von beliebigem Programmcode besteht oder die Gefahr für Denial-Of-Service.   DSA-3799-1 imagemagick —Sicherheitsupdates Auszug der Sicherheitsdatenbank: This update fixes several vulnerabilities in imagemagick: Various memory handling problems and cases of missing or incomplete input sanitising may result in denial of service or the execution of arbitrary code if malformed TIFF, WPG, IPL, MPC or PSB files are processed.   DSA-3808-1 imagemagick —Sicherheitsupdates Auszug der Sicherheitsdatenbank: This update fixes several vulnerabilities in imagemagick: Various memory handling problems and cases of missing or incomplete input sanitising may result in denial of service or the execution of arbitrary code if malformed TGA, Sun or PSD files are processed. This update also fixes visual artefacts when running -sharpen on CMYK images (no security impact, but piggybacked on top of the security ...Read more