Deepin System Updates (2017.12.08)

Deepin System Updates (2017.12.08)

Updated Qt to version 5.6.1 Fixed the black side issue of window problem caused by plugins; Solved the issue of HiDPI thin line. Update TIM to version 2.0.0 Solve the issue that online document can not be opened; The system default browser is used to open an online document. Update Deepin Calculator to version 1.0.1 Specific font is used in historical expression list; Optimized the calculation accuracy. Applications updated and added in Deepin Appstore

Deepin System Updates (2017.10.25)

Deepin System Updates (2017.10.25)

Deepin Emacs Updated to Version 3.0-1 Added real-time format to indent by syntax when writing codes; Added dired-filter mode to quickly filter and display files according to rules under dired; emacs 27.0.50 of the newest emacs git is used to build; Disabled temporary scratch buffer on starting; Added buffer protection to minibuffer-tray, avoiding to exit minibuffer-tray progress when deleting buffer; Added upper case characters and  bound to Alt + z; Migrate multi-term.el plugin to cl-lib repository; Added key bindings for moccur-grep-find-pwd; Fast recursively find words at the cursor and select strings; Added Intelligent indent function for paredit-open-curly-smart; Updated move-text.el plug-in to be compatible with versions later than Emacs 26; Improved C++ syntax highlight; Supported Rust language; Detected g++ command before loading the plugin of auto-complete-clang-extension.el to …Read more

Deepin System Updates (2017.10.19)

Deepin System Updates (2017.10.19)

Fixed System and Application Bugs Cofigurated debconf as a graphical user interface to support some needed interactions in Control Center and Deepin Store; Updated the printer driver; Deepin Voice Recorder updated to Version 2.6.1, fixed the issue that files recorded in mp4 can not be played in phone player and WeChat; Fixed the issue that Baidu Netdisk can not start after updated;

Deepin Security Update——Urgently Fixed wpa Security vulnerability DSA-3999-1 in WIFI Connection

Deepin Security Update——Urgently Fixed wpa Security vulnerability DSA-3999-1 in WIFI Connection

The security updates of wpa. Vulnerability Information DSA-3999-1 wpa —Security Updates Security database details: Mathy Vanhoef of the imec-DistriNet research group of KU Leuven discovered multiple vulnerabilities in the WPA protocol, used for authentication in wireless networks. Those vulnerabilities applies to both the access point (implemented in hostapd) and the station (implemented in wpa_supplicant). An attacker exploiting the vulnerabilities could force the vulnerable system to reuse cryptographic session keys, enabling a range of cryptographic attacks against the ciphers used in WPA1 and WPA2. More information can be found in the researchers’s paper, Key Reinstallation Attacks: Forcing Nonce Reuse in WPA2. CVE-2017-13077: …Read more

Deepin System Updates (2017.10.16)

Deepin System Updates (2017.10.16)

Fixed System and Application Bugs Updated Policykit, fixed the issue that environment variable was invalid; Packed WeChat for Enterprise and fixed the issue of minimization; Fixed and updated Qianniu Work; Added and updated applications in Deepin Store;

deepin Security Updates (CVE-2017-12134 &CVE-2017-12153 &CVE-2017-12154 …&CVE-2017-1000252)

deepin Security Updates (CVE-2017-12134 &CVE-2017-12153 &CVE-2017-12154 …&CVE-2017-1000252)

The security updates of systemd and linux kernal. Vulnerability Information CVE-2017-12134 —Security Updates Security database details: The xen_biovec_phys_mergeable function in drivers/xen/biomerge.c in Xen might allow local OS guest users to corrupt block device data streams and consequently obtain sensitive memory information, cause a denial of service, or gain host OS privileges by leveraging incorrect block IO merge-ability calculation. CVE-2017-12153 —Security Updates Security database details: A security flaw was discovered in the nl80211_set_rekey_data() function in net/wireless/nl80211.c in the Linux kernel through 4.13.3. This function does not check whether the required attributes are present in a Netlink request. This request can be issued by …Read more

Deepin Security Update——Urgently Fixed BlueBorne Security vulnerability CVE-2017-1000250 in Bluetooth implementations

Deepin Security Update——Urgently Fixed BlueBorne Security vulnerability CVE-2017-1000250 in Bluetooth implementations

Armis Labs revealed a new attack vector endangering major mobile, desktop, and IoT operating systems, including Android, iOS, Windows, and Linux, and the devices using them. The new vector is dubbed “BlueBorne”, as it spread through the air (airborne) and attacks devices via Bluetooth. Armis has also disclosed eight related zero-day vulnerabilities, four of which are classified as critical. BlueBorne allows attackers to take control of devices, access corporate data and networks, penetrate secure “air-gapped” networks, and spread malware laterally to adjacent devices. Armis reported these vulnerabilities to the responsible actors, and is working with them as patches are being …Read more

Deepin System Updates (2017.09.15)

Deepin System Updates (2017.09.15)

Updated PulseAudio to Version 10.0 Supported more hardware, now AirPlay hardware supported; Newly inserted USB sound card or connected Bluetooth device, the system will give priority to selecting them as the default without manual settings by users; Improved memory function for hot-swap device configuration; Supported GNU Hurd kernel; Supported 32-bit applications on 64-bit system in padsp. Fixed System and Application Bugs Deep Security Update Fix Bluetooth Protocol Critical Vulnerability BlueBorne (CVE-2017-1000250); Synaptics configuration file back to the previous version, to solve part of the specific model of touchpad can not be use; Update Firefox, Chrome, Opera corresponding Flash plug-in package …Read more

Deepin System Updates (2017.09.13)

Deepin System Updates (2017.09.13)

Updated flatpak to Version 0.9.7-1 Added a new API to the symbol file; Added the required libostree and bubblewrap versions; Security fixed to block some inappropriate file deployment permissions; Added libglib2.0-doc and libostree-doc to Build-Depends-Indep, so that libflatpak-doc can cross-reference these documents; Added a patch to do a more thorough isolation test for $ HOME. Fixed System and Application Bugs Fixed the issue that incorrect  display of sogou input method icon caused by flatpak; Fixed the issue that network can not be connected caused by network-manager; Fixed the translation issue in Deepin Image Viewer; Fxied the issue that alibaba trademanager is expired and can not be updated.

Deepin System Updates (2017.09.08)

Deepin System Updates (2017.09.08)

System updates Synaptics configuration file updates, mainly to solve the touchpad Shiatsu and palm pressure problems, improve the touchpad experience.   Network-manager update from 1.2.4 update to 1.8.2, the specific change log please refer to https://cgit.freedesktop.org/NetworkManager/NetworkManager/tree/NEWS?h=1.8.2.   Wechat fix the bug with black blocks on the desktop.   Deepin Terminal is updated to version 2.6, see https://www.deepin.org/2017/09/08/deepin-terminal-v2-6-0-is-released/.